Streaming live at 10am (PST)

Looking for a scroll - to - anchor point solution

Hi web flowers -

looking for an initial scroll to instigate
an anchor point to a second section of the page…

ie: scroll a bit down (pop) you auto slide to section 2.
scroll a bit down in section 2 (pop) you auto slide to section 3.

Any thoughts?

SB

Hi @scottbarbey ! Thanks for the question. Are you looking to create section scrolling, where you click on a link, pointed to a section and have the page scroll to the section, and then have another link in section 2, that scrolls to section 3 after clicking on the link in Section 2?

This video tutorial may be helpful: http://tutorials.webflow.com/intro-series/using-links

If you need help for a specific site, Can you please update your post with some more information so we can help you faster? Things like your read-only link, and screenshots of the elements in question really speed things up.

Posting guidelines can be found here: Posting Guidelines for the Design Help Category

Regards,
Dave

sorry 'bout that. me big dummy. :slight_smile:

built out my whole site (scottbarbey.com) but was bored
w/ the interactivity on the homepage. boring UX.

Cloned the site and am redoing the homepage.
(an awesome feature BTW)

I’m looking to have my NAV LINKS all jump back to my home page,
but go to specific SECTIONS on that homepage, ala an anchor link…

For example, if someone is on a deeper page in the site,
and they open the NAV and select INTEGRATED in the NAV,
they would jump back to my homepage but it would be scrolled down
to the INTEGRATED section of the page.

my read only:
https://preview.webflow.com/preview/scottbarbey70956011502405-0cd0e7d07ed35?preview=34f7e4a6e8bb4fbe1de121ab85db158d

and one other question…
can I load GIFs into a slider… that is full width?

thanks again -

SB

Hey Scott,

Your site is looking awesome! Lots of fantastic content. :smile:

This is how anchor links work, and to get the effect you’d like to have, you’ll need to add in a full link like this:
http://yourwebsite.com/Page#contentidname

So if I wanted to link to Lucky (little animate dog), on this page here: www.silverdollarcity.com/firemanslanding, I would have to add an ID to the section that the content is in and have this as the anchor link: http://www.silverdollarcity.com/firemanslanding#lucky

In this case, the page name is after the url, and the anchor link is called out by putting a “#” sign and the ID at the end of the URL which in this case the ID is “lucky” :).

Please let me know if this answers your question or if you need any more information on creating anchor links to external pages. :smile: Be sure to update them when you publish a site as well. :smile:

I also found a way to hide the anchor links from the address bar with js, learn more about that here: Smooth Scroll Without Anchor Link Displaying In Address Bar

Thanks,

Waldo

@Waldo -

I’ll give the anchor thing a shot this weekend.
greatly appreciated.

next up… a better nav. :smile:

thanks -
Scott B.

Hi @Waldo

all of portfolio site is done.
Cammot figure what I’m doing wrong on the two anchors I’m trying to make. grrrr. :smile:

so here’s the thing… in my hamburger menu - most of the links go to independent pages…
(like: design, client list, about) but 2 links are supposed to "anchor back to sections on the homepage:
digital and integrated. these are my problems.

My read-only:

https://preview.webflow.com/preview/scottbarbey70956011502405-0cd0e7d07ed35?preview=34f7e4a6e8bb4fbe1de121ab85db158d

ps: appreciated the nice words about the content.
thanks again.

SB

1 Like

Hey Scott,

Awesome work! :slight_smile:

All you have to do is change out your links and they’ll work just fine.

So for the “Digital Stuff” go to: http://scottbarbey.com/#digitalstuff
And the “Integrated” go to: http://scottbarbey.com/#integratedstuff

You were including “homepage” in your addresses which isn’t necessary in this case.
Your portfolio is quite outstanding @scottbarbey :smiley: It’s an honor to help you sir :slight_smile: really excited to see you using Webflow and am looking forward to your future Webflow creations.

Sincerely,

Waldo :slight_smile:

@waldo -
apparently I’m a guy with an outstanding portfolio who cannot make an anchor link… :smile:

so, I realized I may not be explaining myself well enough.

your last post does create a functional anchor link in my hamburger nav… when I’m on my homepage (where the linked sections exist)

However - They do not work when on any other page. When I am on any page other than the homepage… the same links (in the hamburger nav) just drive to the top of the homepage. Not down to the specific sections desired.

So… here’s the $64,000 question…
I can easily make a custom nav for homepage that works the way it does now…
and I can make a different nav for all the other pages - if I could just figure out what I’m doing wrong.

At this point - I’m not really convinced that what I’m trying to do is even possible.
Which would be a massive bummer (because my entire ux is built around it)

can we take one last stab at this?
as always - thanks big time.

Scott B.

Hey @scottbarbey ,

Go ahead and send me a PM and I can walk you through it via Screen Hero if you’d like :smile:

We’ll get this figured out ASAP! :smile:

Thank you,

Waldo

Actually @scottbarbey here’s a quick screen cast: http://quick.as/pdydhdgev

It looks as though you already solved it after I took another look at it? Just remember that using external links will open up new tabs when viewing the site in the Webflow designer view. :slight_smile: Once the site is published it works perfectly. :smile:

May I ask what browser you are viewing the site in where you’re it’s not functioning correctly? It could be (highly unlikely) a caching issue. But shouldn’t be. Feel free to PM me for further assistance/questions. I’ll be online for about another hour this evening.

Thanks,

Waldo

The problem is safari. arrrrrgh!
the links work like a charm in chrome.

I cleared cache, etc.
It’s definitely a safari problem.

Any thoughts/workarounds?

Weird, it’s working for me in Safari? What version and device? Are you possibly on an older iPad?

Thanks,

Waldo

@scottbarbey Just found the issue! :slight_smile: Just drop the “www.” from your anchor links and it should be fixed :smiley:

1 Like

in safari - the links work to drive to correct sections when used on the homepage…

on other pages (at least on my laptop) – the links drive to homepage -but not to sections…

it works!

I cannot thank you enough.
I will rename my firstborn after you.
you rock. you rock. you rock.

muchas gracias amigo!!!

2 Likes

Hahahaha, very happy to be of assistance @scottbarbey
Woot for more Waldo’s in the world! :wink: lol

Let me know if you have any questions or need support in the future. Keep up the fantastic work and we look forward to seeing your future Webflow creations. :slight_smile:

Thank you,

Waldo :smiley:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.