"Locked Class Properties" in Designer UI - New Feature Leak?

When I try to duplicate a class, I’m getting this new “Locked Class Properties” UI element that appears. I think it’s great that this is being introduced, however, when I duplicate class properties I need to be able to edit the properties that are carried over so I can make a new iteration. This effectively locks me out from changing any properties in the duplication?

I haven’t experienced this before and I can’t find any Webflow documentation about this, is this a beta feature that I can turn off for now? It’s messing with my build because I can no longer “copy” classes to iterate on.

Here is a screen recording as well showing the Locked state in more detail:

1 Like

This just happened to me as well. Someone must have pushed the “go live” feature button by mistake…

2 Likes

It just happened to me. I have no idea what command I entered by error and now cannot edit a crucial class.

1 Like

Yup, it’s really causing issues for me as well.

Same thing here! It happend after I’ve tried to duplicate a class there is also present on a symbol element.

I’ve put a symbol, unlinked it and tried to reuse the element, duplicating the classes so I don’t mess up with the other elements – but got this behavior.

It’s really annoying.

Really annoying, every time I duplicate it happens. The strange thing is that when I refresh, it disappears.

1 Like

+1
Glad I’m not the only one experiencing this but hope this gets fixed soon. Not sure if it helps to mention, but I’m working on a site with CMS.

Screen Shot 2022-09-29 at 5.03.36 PM

The same error is occurring here

Same problem here. I need to make a change but I’m locked out. Extremely frustrating.

Okay I thought I was crazy. Guess we’ll stand by for a fix or an explanation, but I’m pulling my hair out over here as I sprint towards a big deadline.

Same, I’m trying to get this build finished and this is seriously a pain in the butt!

Whoa. Following this.

It seems to have gone away after I refreshed the builder. Anyone else still seeing this?

Yep, quietly fixed. :expressionless:

Thanks for noticing that it disappears after the refresh. That works for me now.