Localization problem

HI, i have build a multi-language website www.maestr.nl with polyflow. But now i’m changing it with localization but i need help with two issues. First, the language-change button doesn’t work? and 2: how can i change it so polyflow dns is not the standard anymore?

https://preview.webflow.com/preview/maestr-webflow?utm_medium=preview_link&utm_source=designer&utm_content=maestr-webflow&preview=6e9ea4b2000c4d81a59c6ddcf1cf5da1&workflow=preview

Hey Peter,

The language button is working fine for me, just needs some formatting to space out the choices a bit more.

https://maestr-webflow.webflow.io/en

To revert your DNS settings, just update your DNS back to Webflow’s recommended settings. Remove any scripts you’ve added for Polyflow as well.

Thanks :slight_smile:

Only problem i have is with the dropdown menu’s. I don’t go to the right page? What am i doing wrong?

Ah the other dropdowns-

You’re using direct links, so Webflow isn’t localizing them.
Here’s how you can fix that.

Thanks Michael, i have done it. Great :slight_smile:

I also did this in the footer :slight_smile:

Now up to do the DNS-records :slight_smile:

HI Michael, one last question :slight_smile: I have trouble with the dropdown from localization. I can’t get it the right styling (like the rest of the dropdowns) Can i hire u to help?

Yes I can help, I’ll drop you a DM.