Streaming live at 10am (PST)

Links not mapping to specified pages. Mystery 301 Redirects

Please see the menu in the page footer.
Home: Works Properly
About: Maps to portfolio, although it should be linked to About. When I inspect the code, it is correct. WTH is happening here?
Portfolio: Works
Menu: Works
Contact: Maps to the wrong page. Links to an old version of the page with a different name. Again, code is correct. Don’t know why it is opening this page!

I have had to pull apart both the header and the footer menus to make sure this is not something that I did. But I meticulously checked each link and visually inspected the code. I have no clue what is happening here, and don’t wish to speculate. But these links are correct. The pages being opened are not. Please help.


Here is my site Read-Only: Webflow - DroneGuyCDA.com

Use text links instead of text blocks in your menu.

Hi Doug. I will try that… but why would that make a difference? A URL should be static, a link is a link.

No?

So, I am tearing stuff apart trying to fix this or at least figure out the problem.

I have rebuilt the header navigation. Currently there are only two working links: HOME and ABOUT.

Home seems to work exactly as it should. ABOUT does not!!! It is trying to link to a page that does not even exist! The underlying code is correct and it should be looking for the page “ABOUT” but instead it is looking for a page called “PORTFOLIO.” There currently is no page by that name on the site. I can’t even see where the word “PORTFOLIO” exists in the code. So, all things being equal, it would seem that the issue isn’t text links vs. text blocks. But I’d sure love to know what the problem is. If the code is correct, it seems like this is a server error.

https://preview.webflow.com/preview/droneguycda?utm_medium=preview_link&utm_source=designer&utm_content=droneguycda&preview=e71cdc4ef1046b1821ae2f537406036a&workflow=preview

I have scrutinized this code until my ears bled. I have tried looking at the site in multiple browsers on multiple devices. The code points to the page “ABOUT” but tries to open the page “PORTFOLIO.” The portfolio page is not specified in the code, and does not exist in the site. I have deleted EVERYTHING but these two pages for testing purposes. I created the link using the webflow editor and specifying the page “About.”

I am very comfortable in predicting this is either a server issue or software bug. Leaning to something being improperly cached on the server.

I have wasted way too much time on this… Please, anyone, help me out.

Once you create more pages, you can link to them: Dropbox Capture

Doug, I totally understand. The problem is that I will specify one page exactly as you showed (thanks, btw) but webflow wants to open something completely different when I test the link in a browser. Stuff that no longer even exists. Stuff I deleted BEFORE I completely rebuilt the menu.

It wants to open “portfolio” but I have no understanding WHY it is trying to do that. The page does not exist. I never linked it the way you demonstrated. It’s not cached in my browser.

If you look at the code, you would see the link points to “about” not “portfolio”

I cant even figure out where that is coming from.

So here’s the answer I received from customer support. Essentially, I was correct. This has nothing to do with the code, it’s a server setting. However, I never changed any settings like this, I wouldn’t have even known how. So, I don’t know where it came from, but I wanted to post the solution in case anyone else finds themselves in a similar predicament.

Peace out, girlscouts.

Oh and Doug… even though your suggested responses were incorrect… you were the only one to even try and help me all day long. Just wanted you to know I appreciated it.


Rachel (Webflow)

Sep 29, 2021, 22:31 PDT

Hi Jeff,

Thanks for contacting Webflow support. Sorry to hear you’ve been experiencing an issue with the about link in your Navbar redirecting to the wrong page.

I noticed there is a 301 redirect setup under your project settings that redirects the /about page to the /portfolio page. To resolve the issue, you can delete this redirect by going to your project settings > hosting > 301 redirects: screenshot example here.

After you make this change, be sure to republish your site, and check in an incognito browser window as browsers often cache 301 redirects.

Hope this helps. Please let me know if you have any further issues.

Final post on this before I mark it resolved. In my settings I found not one, but SIX different 301 redirects. My log says that I am the one who set them up, but unless there is an accidental way of doing this, I can assure anyone reading this that I never set up these redirects.

Very confusing and somewhat concerning. But solved for now.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.