Link Block works only in designer

Hi, I am trying to use 2 simple link blocks to connect a page to another, it works in the designer but not when i publish the website.

I tried with both chrome and safari.

The link block is in the project “sci-fi gun” and it’s linked to the page “scifi-gun” and the arrow will send you back to the page “concept-design”

here are the 2 pages:

Thank you,

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Seems there’s a bug with this element on the starting page, you’ll save time by remaking it from scratch, and test at each stage if the link is working.

Giuseppe the work showcased here is outstanding :slight_smile:

1 Like

Thank you.

I managed to solve the problem. I had to delete some custom scripts. I don’t know why but they were causing some problems.

now I have another 2 problems.

  • despite I don’t have the “open in a new tab” option some of the links open in a new tab randomly.

  • when the pages open there are some glitch and flashes in some of them. why?

After seeing your website and how cool are the things you worked/created, I can’t help myself but to help you with everything.

I don’t know what were you doing before with the link inside the link block, but you can always use a bit of javascript to create a “go back” button. So the user always goes back to where it came from.


<button onclick="goBack()">Go Back</button>

function goBack() {

Now your second problem: Do you have any custom code on the project settings of your project? Would you mind sharing them with us?

1 Like

Thank you :), I just saw your reply.

Yes the structure is a bit weird because I’ve changed many designs. at the moment I’m working on the page “concept design” and all the projects related to that page. I just decided to link each project to another page instead of using the modals.

  • I solved the problem of the links that were opening in a new tab even if i didn’t want to. Yes, it is a bug, because I had to click on and off the option “open in a new tab” a few times to make it work. just like you have to switch something on and off to make it work again.

The only problem I have now is the load page animation, which is a “fade in” interaction. Sometimes it goes smooth and sometime flashes.

I am assuming it’s because is trying to load the contents at the same time is fading in ?

can anyone help me to figure this out?

maybe the solution is making the page loading the content first and then starting the quick fade in animation?

All you need to do to fix that is change the “when” the animation happens. Right now it happens “when page starts loading” and you want to make it start when “page finishes loading” like the image below.

Thank you! it works way better now.

1 Like

Glad to help! I loved your work man! Keep it up! But I gotta ask. Are you actually the guy who designed the 3D model of the Delorean in the movie? Or at least part of it?

Yes, I made the whole model. It took me almost a month but it was worth it.

Thank you again!

1 Like

I loved that movie and the DeLorean was really well made! Great job @Giuseppe! Feel free to get in touch in case of need for any assistance

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.