Streaming live at 10am (PST)

IX 2.0 Not responding to vertical mouse movement

I’m trying to create an animated footer, where layers of waves and a whale move slightly with the mouse.
The Y axis is not responding to my mouse movement at all on live preview, even if I publish the site it’s still not making the Y axis animation take effect.

I’m using Mac High Sierra with latest Safari, and I’ve tried on the latest Chrome too.

When I move the mouse outside of the viewport, it just defaults to 50%

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi @magicmark can you please post your read-only link?

I’ll be standing by for your response.


The amount of time I’ve said to people to share the link, and I forgot myself!

It’s the Test Page.

UPDATE: It’s now responding. I’d exited the designer and reloaded it and is now working)


Nice little effect there @magicmark - fits the site really well, and I can imagine a children’s narrator on Jackanory telling the story while the whale moves!

1 Like

Thank you so much @StuM! :grinning: Those are the first illustrations I’ve ever done, and had that idea for a while. Very pleased you like it!

I’m still having some issues with this.

The Y movement is not working on my footer when the screen is longer than 100vh.

It works on the page, then when items are added it stops working, but the X Axis movement still works.

My share link above is still active.

@magicmark Did you fix this issue? I have the same problem.
The Y movement is not working when the screen is longer than 100vh.

No it’s still the same, really have no clue what I’m doing wrong. Sorry you’re having this issue too but glad it’s not just me! :joy:

Anybody that could help please?

Hi @magicmark

Sorry to hear about the interaction trouble.

Can you provide a screen recording of the issue?

​Thanks in advance, and I’m standing by for your reply.

Hi @Brando

Video as requested. My share link is still active too:

Look forward to your reply.

Thanks for sharing this video @magicmark

I’ve passed this along to our team to see if we can figure out what the issue here is.

I appreciate your patience while we investigate this further.

1 Like

Hi @Brando

Any news on this do you know?

HI @magicmark no updates on a fix for this yet.

However I do have a workaround that you can use. You can use the mouse move over element animation trigger rather than in viewport. In this case, you can set the trigger on the section, and have water & whale pieces animate.

I’ll post back here as soon as I have an update for you.

1 Like

Thank you for the workaround idea, I’ll use that for the short term.

1 Like

Markos, I had this issue on my personal portfolio with the On Hover Element with Interactions 2.0. It seemed to have stemmed from a Z-Index issue. Try checking some of the Z-Indexes of your Div containers.

I hope this helps. Nice website by the way! You should be proud of that.

1 Like

Each layer of the footer has its own z index so sounds like you may have found the issue! I’ll try it and post back.

[quote="Nice website by the way! You should be proud of that.

Thank you so much. That’s made my morning! :grinning:


Glad I was able to help man! I remember I lost some sleep over that issue, but I found it out haha.


I never got round to changing this to the suggestion above, but just to let you know the issue seems to be resolved. If you did something, thank you! If you didn’t, thanks for everything else anyway. :webflow_heart:

1 Like

Hi @magicmark

Thanks for letting me know! And yep it looks like our team was able to close this issue :tada:

Thanks for pinging me on this and apologies for the delay.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.