Issues with Div at bottom of Footer (below container)

I am at my wits end here, and could really use some assistance…
Unfortunately I can’t share a read-only, as it is an unfinished site for a client.
However, there is nothing complex about it, yet the issue persists…

So here’s the situation/issue…
I have a very simple Section acting as my ‘Footer’.
Inside that, I added a Container.
In the Container, I added a Columns element: 3 Columns, which all contain simple text.
(Here’s where the issue comes in)…
Underneath the Container, I have a DIV, acting as a Copyright bar at the bottom of the page.

For some reason the DIV is getting chopped out of the page entirely!
In Preview view, as well as in the Designer…
It’s almost as if everything is cropping up to the very bottom of the Container itself.

I’ve tried everything to fix this issue, but to no avail.
I even tried removing the margin above the DIV, but still no luck.

Any thoughts?
Please and thank you…

PS. The only Fix is to give the Section a fixed height until the DIV bar is shown.
But even then, then I click a link in my navbar (which scrolls to the Footer), it shows extra space BELOW the DIV bar! And then when I scroll back up and down, it goes back to normal again.
I’m at a total and complete loss here…


No way to help without a link (Your issue related to specific case).

If you have privacy issues - copy-paste the page to new project. Remove all logos images and sensitive text and share this link + read-only + add screenshot of the problem.

Ahhh alright, how do I create a read-only link? I guess if I don’t figure this out, the site wont do much good anyhow. So let’s do this.

Share a project’s read-only link

Omfg, now when I publish it to a webflow io domain and click on the navlink that brings me down to the footer, it actually shows space BELOW the DIV bar at the bottom… What in the world is going on here? Let me get you guys a read-only.

Ok so it’s working perfectly now when I publish it. Only problem is, in the Designer, it’s cutting off everything below the Container in my Footer Section… So that’s pretty odd.

Maybe this related to global interactions(page load and so on). Or global styles (body styles and so on). Both won’t copy-paste to new project.

That could be possible, as I did copy/paste a thing or two… But I only copied and pasted 2 sections - the Footer, which I completely re-built from scratch to try and fix the issue already, and then after that, I also tried troubleshooting by completely deleting the OTHER copied Section, leaving ZERO copied Sections… I checked the interactions tab, and its empty… And I also cleaned up my styles list… Would the fact that I had previously copied/pasted something that had an interaction of some kind be able to cause this issue I’m having, even after removing the section I copied after the fact?

Sorry again no way to help by story (Only by link :)). Disable JS to find if this issue related to interaction.