Issue with Webflow and Intercom (subdomain)

Hello, I have a website hosted by webflow with a domain name from Godaddy. Had it for a while and it runs great.

A few days ago, I created a new subdomain in my DNS settings on Godaddy called “Docs”

I created it because I want the subdomain to have Intercom Help Center articles.

To launch the INtercom Help Centre, Intercom asked me to make a new CNAME and when I did that, i get an error in my Webflow hosting dashboard for this new subdmoain:

“You’ll need to remove the AAAA record from your DNS settings to ensure your site loads properly.”

However, I don’t have any extra AAAA records.

When I try and visit the subdomain, I get this error:

Error 1001 ## DNS resolution error

I suspect this is an issue with Cloudflare, but I could be wrong.

Anyway, does anyone have any experience setting up an Intercom Help Centre on their subdomain where the main domain is hosted by Webflow? Is this even possible? Does Webflow allow you to have Intercom help Centre on your subsdomain?

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hey Young, what domain?

Hey @youngjnc

On Webflow, you can’t have more than one domain go to a site. So in this situation, the subdomain is only needed for your domain registrar, not Webflow. You set this in the DNS settings of GoDaddy (just like you stated). There’s nothing needed to enter into Webflow, it all happens on GoDaddy’s server.

The Intercom account will have these settings. You’ll set the subdomain for the help center in Intercom to point to that DNS location from GoDaddy. Inside your Intercom account, you’ll get a URL. This is the link you’ll use inside Webflow using a navigation link. It will show that subdomain in the address bar when a visitor clicks that link. It provides a seamless user experience, so they don’t know they left your site. The subdomain CNAME in GoDaddy allows it to be found on the online. But Intercom is actually going to host and show the help docs page, not Webflow.

You shouldn’t need to remove any A records. That’s only if you want your primary site hosted with the subdomain on Intercom.

Let me know if you get stuck :slight_smile:

Thanks alot. This worked!

Thanks for offering to help, but I just fixed it from @garymichael1313 answer.