Issue with Metadata


I’m hoping you can help me understand something. When my client searches for the site that I created: he gets these results. The issue is that as you can see, the first result shows 2019. I can not see where to make this change. Please advise.

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

From where and what was the search?

@webdev From Google. The search is

If you only search datta solutions group, it does not show up. But when you search the entire address it does.

The best check is using * which will show indexed pages in Google’s index. If a SERP title is stale, expect it to be updated as Google refreshes its index. Use Google’s Search Console → Google Search Console for more insight.

I tried that search and got the same exact results. This displays the link title with the 2019 on it. its Important to my client that the first result does not display 2019. I don’t understand why this is happening when the site doesn’t have 2019 on it. Do you know how I can change this?

Google displays SERP content based on a variety of factors. The old site index may have had that string in the meta title. Use Googles search console is the only way or just wait.

@webdev Do you have any tips of how to use the search console? I am not familiar with it, or how to update site indexes.

The product is well documented by Google. Start there. You can hire me as an option.