Issue with finsweet rich text attribute


I’m trying to embed a div inside a rich text for the first time on my friend’s website.

I think I have everything set up but it does not work.

The usecase is pretty simple as shown in the pictures below. I have {{CEDT}} in my rich text component and I have a div that has CEDT as identifier.

Maybe I’m missing something…
Read-only link

I would greatly appreciate the help.
Thank you very much.

Anyone able to help me?

Hey @Joachim_B, My theory is this doesn’t work too well with collection template pages. I tried running the script on a static page, a collection template page, and as a collection item on a static page.

The only scenario that didn’t want to run properly was the collection template page. I would join the @Finsweet attribute slack group and see if there’s a running issue in that group.

1 Like

Thank you for answering!
I have asked there! :slightly_smiling_face:

1 Like

Solved! Finally!

The attribute does not work if my identifier is CEDT, I changed to cedt-component and it works.

Damn that was hard to figure out.

1 Like