Streaming live at 10am (PST)

Issue Renaming Collection Item - Mixitup JS


I think this one’s a bit strange - I’ve ran a few tests myself, but haven’t had any luck. I’ve probably missed something, was really hoping another set of eyes might pick it up!

Basically, I’ve used the mixitup JS in the past with no issues. As you can see on this project its working as intended.

However, I can’t get this to apply to another one of my projects in a similar way. The structure is almost identical, so I am unsure why I am getting issues. The one glaring thing is that on logobuckets I can see the class name change:


But on the flowtips projects, I can’t see the ‘mix’ label in the layers view, despite it definetly having the class applied.


Would really appreciate any ideas!



Hey @Thomas_92 I can confirm what you’re seeing. Not matter which class is applied to the collection-item element the class name is not reflected in the navigator or the breadcrumb bottom bar of the canvas. That does seem like a bug.

However the .mix class does appear in the code for the published site so the bug does not seem to be affecting it there. I do notice that your buttons have the class sort-button instead of filter-button. Fix that and republish to see if that resolves the issue.

Hope that helps.

Hey @matthewpmunger

Thanks for taking a look, interesting to hear that you also cant change that class name. Seems strange!

I’ve tried using the other class name on the buttons without luck, and can also see through inspect that mix is being applied to the element when deployed.

Ill keep the post up, but might have to reach out to support directly.

Thanks :slight_smile:

@samliew @vincent

Mind taking a peak if you get a sec guys! <3

Hi @Thomas_92, thanks for the report, that is strange about the class renaming on the collection list, I am helping to take a look at that further.

A temporary workaround is to create a new collection list and cut/paste the field elements from the old list to the new list and delete the old list.

I made a quick video:

I hope this helps, I will update when I get more info on why the class could not be renamed.

Thanks in advance

Hi @Thomas_92, it looks like the container class in the header section is messing with the mixitup plugin behavior. Remove the first container class from the header section, then republish the site, I made a quick video:

I hope this helps


Hi @cyberdave,

That has worked perfectly! I knew it would be something minor, but lesson has been learnt! I really appreciate you taking the time to clearly go through, make videos and help me catch this issue.

Hope you have a great day mate,

Thanks again

1 Like

Hi @Thomas_92, no problem, happy to help. I know that sometimes multiple eyes on something is the best way to find something small like that.

Glad to hear it is working :slight_smile: Now, just imagine when we get dynamic filtering added to Webflow, that will be awesome ! :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.