Streaming live at 10am (PST)

Is this a bug? Weird Div behaviour

Hi everyone! This is driving me a little crazy and I’m hopeful that someone out there has seen this before.

I have a div (filters-vertical) on three different pages. The settings and design are identical on all of them with only the selectors being different.

Inside the editor and on preview everything looks and works okay. When I publish to live, only 1/3 pages show the filters-vertical div.

I have to think it’s something I’m missing but after hours of going over the settings with a fine-tooth comb, I’m starting to question if it’s on Webflows side. Has anyone else come across this before?

Here are the links to the 3 different pages:
Home
Sandal Collection

Winter Collection


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

I just looked at your home page and it appears you are loading some JavaScript twice. Try cleaning that up and see if it resolves your issue.

Thanks Jeff, appreciate you taking a look :slight_smile:

I’ve just gone through and removed all unnecessary Javascript, sadly no luck.

I inspected the code on chrome and can see that the display ins set to none (attached)
image

But on my editor, filters-vertical is set to flexbox

Not sure what is causing this to change once published.

Cheers!
Adam

Do you have the style block below in your project settings -> custom code -> before body area?

<style>
    @media (max-width: 991px) and(min-width: 768px) {
        html.w-mod-js: not(.w-mod-ix) [data-w-id="1a167582-7d2e-15b3-07c9-95a264f765f9"] {
            display: none;
        }
    }

    @media (max-width: 767px) and(min-width: 480px) {
        html.w-mod-js: not(.w-mod-ix) [data-w-id="1a167582-7d2e-15b3-07c9-95a264f765f9"] {
            display: none;
        }
    }

    @media (max-width: 479px) {
        html.w-mod-js: not(.w-mod-ix) [data-w-id="1a167582-7d2e-15b3-07c9-95a264f765f9"] {
            display: none;
        }
    }
    </style>

I don’t have time to debug your project right now but would mention that you don’t need to load the Finsweet cms library twice. Once is all that is needed.

1 Like

Thanks Jeff, I appreciate you taking the time you already have.

Nothing like that in my custom code, just the below:

Very confused as I don’t recognize it at all and the site was working perfectly until recently.

Thanks for the heads-up on the finsweet library, removed one of the lines so it’s not duplicated.

Cheers!
Adam

Turns out it was an interaction that was messing things up.

Thanks again for taking a look, help from people like yourself are why I stick through the steep learning curve of webflow.

Cheers!
Adam