Interactions broken on exported site

UPDATE: Okay, the whole backstory is still below, but basically, there are 3 interactions/animations that are broken depending on where the site is placed on the server; works perfectly, but the exact same site (same files) moved into the root directory causes the interactions to break.

Anyone have any ideas why? It’s doing my head in! :slight_smile:

Because I need it to be working, I’ve removed interactions on the problem elements in the public site, but you can still see the problematic behaviour

Hey all,
I’m… super confused right now. I’ve exported my site and, in the staging directory, it works perfectly, but in the public directory, 3 interactions are broken. So strange!

Staging/live testing directory:
Public directory:

In the public directory (i.e. my live site), the colourful Find Your Sound logo and 2 lines of text above it (PUZZLE FACTORY:‍ THE RECORDING STUDIO) are not displayed, yet they display perfectly in staging.

My first thought was that I hadn’t copied the Find Your Sound logo (FYS) image, but it is definitely looking in the right location and the image file path does contain the correct image. Then I realised the text was also missing and broken image wouldn’t explain that. Strangely, the 2 buttons underneath are working fine.

Anyone have any ideas?
IIRC, interactions have ID numbers and it can cause problems if they’re different from what they should be, but not sure why directory structure would be enough to break it.
I know that I created those 2 (legacy) interactions specifically for this version of the site. (Previous version of site had other text which also had interactions. They always worked fine.)
Or maybe the interactions are not being triggered, but why?? They work fine in the Webflow-hosted copy of the site, too.

Sincerely confused,

Here is my site Read-Only:

Aha!! Yes, I’m certain its related to interactions.

I’ve just spotted another difference: the fading/flashing/moving arrows at the bottom of the first page (powered by an interaction) don’t disappear as they are supposed to on the public site, but (you guessed it) they act as expected on the staging site.

I recall having some problems getting them to work properly in the past, but can’t remember how/what the problem was.

Still not sure why those arrows would be broken depending on directory, though.

I would be happy to rebuild those arrows if anyone knows of a better way to make them.

Thanks and all the best,

Hmm… I have completely removed the Pulsing Arrows div from a copy of the site’s main page, but that hasn’t solved the problem.

did they ever get fixed? if yes, how and what was the problem?