Interaction 2.0 bug – Animation shows correctly in animation editor, but not on published site

I’ve been working on my custom mobile navigation: Simple hamburger menu that shows the menu div on click, hides it on second click. Now, if you check the read only link and go to the animation to preview it, it does exactly what it should. But publishing it makes it not display correctly

What it should look like:

What it looks like on published site:

Now, the weird thing is that this interaction worked perfectly until I made a symbol out of the navigation wrapper (.l-mobile-nav). After it broke, I deleted all symbol instances and deleted the symbol itself. Then I tried deleting the interaction and making a new one from scratch: The problem persists.

Does anyone have a solution for this?

Here is my site Read-Only:

I solved it by deleting all the classes and interactions and starting from scratch.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.