Importing 4000 wordpress posts to Webflow, can't keep tags, authors, or category

I am having a massive issue that I can’t believe is a Webflow problem.

I have 4000 post to import from Wordpress, we are moving our Blog to Webflow.
The 4000 post CVS file (which IS properly formatted), I broke up into 5 files, since the 1 big file is 10 mb and too big to import.

The old posts have categories, tags, and authors

  • I imported and created a collection for each, Author, Category, Tags, and imported all of those (236 tags, 28 authors, 12 categories).
  • When I import the first CVS file, all the fields map correctly (I map Author to a Reference field for “Author” collection, I map Category to the MULTI reference field for “Cateogry”, and same for tags).

The posts import. But no matter what I do, I can’t get the old author, tags, and categories to link back up. They import as empty fields. I don’t have the time or manpower to manually key in those entries for 4000 posts. I have tried everything? What am I doing wrong?

I have even zeroed out my blog posts, and created two from scratch, with chosen authors, tags, and categories, then exported THAT CSV file from Webflow, deleted the posts, and re-imported them back in, with the WEBFLOW CSV file. It imports with those three fields BLANK. WHAT THE HELL?

Even Webflow’s importer preview recognizes the entries in those fields. But when I run the import, those fields are blank. I need this to work for the client. HELP!?

Surely I am not the first person to import Wordpress to Webflow with categories, authors, and tags. How do I get this to work?

MY COLLECTIONS: tags, authors, category, blog posts

MY SETTINGS FOR EACH BLOG POST FIELD TO REFERENCE FIELDS




MY IMPORT FILE MAPPING, you can see if recognizes author, category, tags

as you can see from the last image, the Author, Tags, and Category are recognized by the Webflow importer, but when I import, those fields are EMPTY… whether I import 1 or all 4000 posts

Hi @Michael_Lawrence thanks for your post, the Webflow team is aware of the unexpected behavior with the references and multi-references with the CSV import and are currently investigating.

Another option while that is happening is to use the CMS API, we are not having reports of issues with the API imports, only with the CSV at the moment.

Another method workaround while this is being checked would be to import the CMS items via a service like Airtable or Zapier, powerimporter etc, which allow you to use API methods but with a no-code UI.

I am here to help and will post once there is an update.

Hi @cyberdave, so WF is aware of an issues importing CMS reference fields?

I’ve had a WF ticket open for nine days now, with no insight into this issue. I’ve been trying to figure out how to import items via Make and Airtable with no luck. My project is dead in the water right now. Extremely frustrating. Does WF know what the issue is? Is there a timeline on fixing this?

Thanks.

Hi @Michael_Lawrence have you had any direct update from WF regarding this? I’ve been having the same issue for the past two weeks. I have had a support ticket open for nine days, but no update yet. I’m surprised more people aren’t speaking up about this. This should be a top priority for WF.

same issue here, still can’t do a bulk upload and maintain tags or categories. Anyone had luck with this?