Images appearing in Webflow editor, but not published site

Hi everyone!

Would really appreciate some help on this. When I visit this page on mobile, the images on this page don’t appear, as you can see in this screenshot:

However, when I’m in the Webflow editor, they never disappear.

Does anyone know what could be the cause? Thanks in advance!

Here is my site Read-Only

Webflow is incorrectly setting the sizes attribute of the .allow-images img elements it generates as part of the responsive image process. I would wrap those images in a div to see if that fixes it after republish. You could also indicate to Webflow not to use responsive images for those elements. This sometimes occurs when images are direct descendants of a parent with display set to grid.

To disable this feature for a specific image (e.g., if you need to force the browser to use the original image size):

  1. Select the image on the Webflow canvas
  2. Type Command + Shift + O (on Mac) or Control + Shift + O (on Windows)
  3. Open Settings panel > Image settings
  4. Uncheck the Responsive image checkbox

That worked thank you! At first it didn’t, but then I set the divs to display flex! Appreciate your help!

Hi Jeff, I put the images in divs, and that worked at first, but now I am checking my website, and the images aren’t appearing again. Do you have any suggestions?