Image files from CMS not displaying in collection list

I’m working my way through the “Creating a custom portfolio” course on Webflow University and am experiencing problems replicating what’s described in part 6 of the tutorial, about 2 minutes in. At this point, I’m adding an image element to a collection list, and linking it to a CMS, which is supposed to then populate the collection list with images, but that is not happening.

I’ve made a 2-minute video demonstrating the issue here:

If anyone could share their insights as to what the cause of the failure is, I would appreciate it.

Thanks in advance.

Here is my public share link:

1 Like

I noticed the files are SVG’s. In this case you have to specify the width and height of the SVG image. Try that and I’m sure it will work :slight_smile:


1 Like

I just tried it myself actually and it’s not working. That’s odd. @vincent or @matthewpmunger Any ideas?

1 Like

@Chuck_Braman can you copy the 5 first lines of the .csv here please?

Thank you very much for looking into this, @Noah-R and @Vincent.

@Vincent, here are the five first lines of the .csv (I’m assuming you just want the first 5 image URLs that are in the 2nd column and not the names of the logos that are in the preceding column):

@vincent I could be wayyyy off here but being that these image files are coming from another webflow sites asset library, could it have something to maybe do with if let’s say the site isn’t published or something along those lines?

You’re assuming right :slight_smile:

As long as you can view the image with its URL, then you can embed it anywhere without trouble, that’s the check I wanted to do. And we can indeed see the images with the URLs. But I get your reasonning and its valid, depends how CDNs are set.

@Chuck_Braman , what happens when you download one image and add it manually to one collection item? It works, right?

I’m sorry, @vincent, I didn’t notice the question to me that you amended to the end of your post last week until now, and I actually had stopped working on the tutorial around then.

No, if I download an image and add it manually it still doesn’t work.

In any case, thanks for looking into it and no worries at this point if you can’t solve it.

I have the same issue. Help will be much appreciated

Hi @Daniel_Aganga and @Chuck_Braman,

You guys can reference this feed as well for any additional answers.

Happy Designing,

1 Like