Image asset pixel size dropping to 0 x 0

Hi y’all. I’m having a weird problem with my image assets. I keep deleting, re-uploading, and re-linking them because after a day or so the image size drops to 0 x 0 pixels. I wouldn’t notice except in the preview AND published site the image loads fine but after a few seconds the images are shrinking to tiny thumbnails. Is this a bug or am I doing something wrong? I need to get it fixed!



Screen Shot 2022-07-27 at 2.21.26 PM


Here is my site Read-Only:
https://preview.webflow.com/preview/neapolitan-co?utm_medium=preview_link&utm_source=designer&utm_content=neapolitan-co&preview=fbdc3d2427592eaa81adf62d35b15890&pageId=62d995c9f061d40e43d4f843&workflow=preview

Here is my published link:
https://neapolitan-co.webflow.io/work/scs-studio

Did you ever figure out how to fix this? I’m having the same exact issue… Took me forever to figure out this was the cause of the image size shifting all the time :weary: At this point I’m just re-uploading the effected photos. But if you figured something out, let me know!

Sort of… I opened a case with Webflow and they said it’s an internal bug that they’re working on. I think the issue was caused by deleting the image from the asset panel without first deleting all of it’s uses in my layout. Then when I re-uploaded files (purpose was to compress file sizes) there was still trace of the file in the server and it glitched causing the 0x0 file size. While they work on a fix I just renamed my files before re-uploading the and the issue was resolved.

Just have to make sure the images are fully removed from the layout before deleting from the asset panel in the future.

Hi @SaraNeapolitan,

I’m having the same issue, I contacted support but have not heard from them yet.
I had previously optimized my images prior to uploading them and they shrunk a day after they were uploaded.

@erinternes I’m having the same issue and it’s discouraging!
:disappointed:

Let me know if you find a solution.
Hope you contacted support as well!

@jojokats I’m also having this issue. I’ve tried everything. Hopefully Webflow fixes this soon!

@livstrawbridge, I noticed that this was happening when I was loading images that were too large in size so I tried making them smaller and noticed that I didn’t have this bug anymore.

@jojokats interesting! I’ll keep that in mind for next time. I ended up fixing it by typing in the actual size of the image in the settings panel and that worked also.

I removed the “solved” from this thread because I’m having this issue again with all new images. My images are around 3200px and under 500kb. They’re all set to 100% width - I don’t want to add exact dimensions because I want to keep them variable. Has anyone figure out what the heck is going on with this issue? I wrote back to WF on the same ticket as before, not sure if they’ll have an answer for me. This is a serious issue, I can’t understand why it’s happening.

I heard back from WF and they responded with the following:


At this time this is still currently being investigated for the root cause by our Engineering team. I wish I could provide a timeframe as to when this will be resolved, but we don’t quite have one at this time.

As a potential workaround to this issue, please try to disable the responsive image setting by performing the following steps:

  1. Select the image(s) on the Webflow canvas
  2. Type Command + Shift + O (on Mac) or Control + Shift + O (on Windows)
  3. Open Settings panel > Image settings
  4. Uncheck the Responsive image checkbox
  5. Publish the site again

For more info, see the following: Webflow University | Disable responsive images

@SaraNeapolitan if you type in the actual size of the image in the settings panel, you can still override these size settings using a class, so you can keep them as variable (ie with % or VW etc). This worked for me (I got the same reply from Webflow recently, unchecking the responsive image checkbox didn’t work for me).

Still experiencing this issue as of January '23 on multiple site projects.