Streaming live at 10am (PST)

Hyperlink in rich text

I have a rich text block that takes its text from an article in my collections section.

Therefore, I can only edit the text within the collections editor.

When I add a hyperlink to a word or phrase, it looks fine in the collections editor, but when I return to the designer, the hyperlink is on its own line, separated from the rest of the text.

I looked at other solutions to this issue that change the layout of the hyperlink to ‘inline’, but I’m unable to do this because the text is pulled straight from the collections.

How can I make the hyperlinks stick to the line they’re supposed to be on?

Thanks


Here is my site Read-Only: LINK

Hello Matatat! Have you tried to create a new class for you rich text, and nest the link selector to that class? So basically what you have to do is:

  1. Add a simple rich text element
  2. Add a class to it
  3. Add a link
  4. Now select the link (All Links) from the menu
  5. Click on Nest selector inside of “class name”
  6. You can make all the links in your rich text inline block
  7. Add that new class to your rich text in your collection.

You can also check out how to do it here

I think that should work for you, if you need anything else please let me know! :raised_hands:t3:

I have the same problem and your solution doesn’t help. I cannot add anything to the Rich Text because it’s getting its content from the CMS collection. What should I do? My hyperlinks are all white and change colour when hovering over them, but I cannot access them individually since they are set as hyperlinks in the CMS.

Did you figure this out Stephan?
Facing the same problem.

Any help is appreciated:)

Yes I did, if click on any hyperlink and check the tag in the top left (should be called Link), you will notice there is a little arrow next to it. You can click on that arrow and a dropdown will appear that says “hover” and 3 other options, I think. Click on hover and you can change the styling. This should apply to all the links on the page :slight_smile: I hope that helps!