How to publish a chosen page from a folder? Simply publishing different page does not work

I purchased this ecommerce template which has different Pages with different layouts. Those pages are nested in Folders. Can not find an easy way to publish one or another Page. I am stuck with what was set as default Page from each folder. Where do I change that? I see that there is a CMS collection created for blog posts. There is a BLOG folder with 3 Blog layouts in it as different pages. Simply publishing the one I want does nothing. Tried to change URLs and it seems that I messed up something as non of the Blog Pages show now and it says PAGE NOT FOUND.

How do I pick and publish any page from a folder?

Here is my site Read-Only: Webflow - Nordlab Store

Hi @Senetron3s

When you publish the website, it will publish all pages. You can decide which page is the home page by clicking “make your home page” in the pages settings. You can create links to different pages. Folders are there for link structure.

It sounds like you are new to Webflow. Have you had a chance to look at Webflow University? There is great informative content there that will get you right up to speed.

Hi @Smith-Cordell Smith-Cordell,

Thanks for replying. It does not publish all pages. Just one from a folder. I have three pages in Products folder and it publishes only one out of those 3. The same with Blog folder. It only publishes one page and I can not find how to publish different page than it does. I watched all the damn videos about Pages, Folders, URLs etc. Can’t find how to publish other page than it is set by default.

It’s all good with Home page. But I can’t publish different Blog page or Product page from what I have in those folders.

Hi @Senetron3s

Each page will have its own address within the folder. I’ve taken some screenshots which shows this.

The structure is as follows:

At the moment it looks like you are linking to the Blog2 page on your site. If you want to change that, simply change the page links to a different blog page.

Okey, got it. Thanks!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.