How to notify successful webhook call

I have a webhook on my site which triggers the desired URL correctly and does everything it is supposed to. Despite being successful, it still retries 3 times with a 10 minute interval.
I am assuming that the url does not return the proper formatting to notify the webhook of success which is causing the failure retries. What fields and format should my response to the webhook have to notify it of success.

Welcome @parker.wilson :wave:

I’d need more details to help you. Are you speaking to Webflow Webhooks? If so which one specifically?

Thanks

1 Like

I’ve seen this on Webhooks like user_account_created.

Make sure your endpoint is returning an HTTP 200 response code. Outside of that, @ChrisDrit is more familiar with the webhook content structures and might have advice if you identify the webhook you’re using and the exact response your endpoint is sending. Make sure to include your response headers too esp encoding and content-type.

1 Like

Yes, I added a webhook under ‘Apps & Integrations’ through the site settings on the dashboard.
Trigger Type - Form Submission
API Version - API V1

The webhook is a call to the AWS API Gateway which then triggers a Lambda Function which has API Calls within that. This was done so the Lambda function can act as a hub and allow data from the form be used in multiple different automations.

Response headers are standard AWS headers and content-type is JSON. I have included a header response below.

Method response headers: {X-Amzn-Trace-Id=Root=1-6514622f-38540fe94ca538874ead46ba;Sampled=0;lineage=dgd08158:0, Content-Type=application/json}

Is it returning a response code of 200?
Theoretically, Webflow’s webhooks dispatcher doesn’t care one bit about the payload, because they don’t do anything with the response. They simply need to know it was received ok, or else they’ll retry.

1 Like

Amazon reports “Method completed with status: 200” so I assume so, if the webhook dispatcher only cares about receiving the 200 code, I can look into manipulating the response.

Besides the 200 status code is there any specific headers that Webflow requires be returned after a webhook call?

Have you used postman to verify?

Nothing I’ve encountered. Typically my endpoints return application/json content encoded utf-8, but I really don’t think the Webhook dispatcher cares. If you don’t see anything in the docs, you should be fine.

Verify that 200 before you waste time on anything else, that’s a must.

1 Like

I believe your webhook endpoint just needs to return a 200 response. Otherwise, it will keep trying as you’ve mentioned.

I’d trying hit your endpoint directly with Postman like Michael mentioned to ensure it is in fact returning a 200 response.

1 Like

A few things to try…

The Webflow Webhook

You mentioned using the v1 API. I’ve been finding wonky issues with that since Webflow released v2 beta, and now v2.

The first thing I’d do is send the Webhook to this site instead of AWS: https://webhook.site/

Make sure what’s being sent looks correct.

Using Make (Integromat)

AWS services, including lambda can be complex beasts at times with settings hidden in unintuitive places. What appear to be simple settings may totally alter how it behaves without you even realizing it.

To continue your investigation, just setup a quick, and free Make (Integromat) account and send your Webhook to that.

Does it work?

Postman / Insomnia

As has already been mentioned, if the 2 tests above prove successful, make a POST via one of these tools.

A lot of folks recommend Postman, but it’s too much for most use cases. Use the free and open source Insomnia client instead (if you don’t already use Postman) and you can test this much quicker.


After running through all of those tests the problem should show itself.

If not…

Post your curl statement to the lambda endpoint.

1 Like

@jonohale What’s the backoff and retry strategy for the v1 API?

Using Postman and webhook.site showed the issue. Thank you all so much for the guidance of how to find the problem! I’m pretty new at this so I really appreciate it.

2 Likes