How to make default domain.com using AWS

Hey,

I want to make the default domain as mydomain.com instead of www.mydomain.com
i setup the A record to webflow ip addresses.
i setup the cname record to the webflow proxy address.

When i switch webflow default domain to mydomain.com i get an error of to many redirects.

I am using AWS route53 tool to manage my dns.

Webflow support keep telling me to move my dns hosting to cloudflare but i can’t and i want to keep it on AWS route53.

My question is, do you know how to make default domain.com using AWS services ?

Thank you very very much for your help.

1 Like

Did you ever get this resolved?

I’m in the same boat…we just ported over a massive website but the company uses AWS route53. Moving dns providers isn’t an option. The current website is at mydomain.com so moving to a www version is definitely far from idea.

The confusing part is that on wpengine we are able to use Route53 to have ssl at the mydomain.com root level, so I don’t understand why this seems problematic on webflow.

Any update or pointers welcome,

Thanks

Any news here?

I’m having the same issue, curently engaging with Webflow support. While it works with a test domain and Cloudflare, I would really stick with Route53 for the real domain.

Would be a first bitter taste for moving to Webflow.

@thomykay - There really is only really one option if you want to stay on Route53. Host the site on www or another subdomain. Technically a proxy server could be spun up that reverse proxied the www subdomain but you may run into issues with certificate renewal on the Webflow site.