Streaming live at 10am (PST)

How to add custom fonts to webflow

I have read multiple threads in here in regards to adding fonts that are not on typekit/google. But I must be doing something wrong, because I can’t get it to work.

I am looking to use font-family: ‘Gotham Rounded SSm A’, ‘Gotham Rounded SSm B’; from

I have this link <link rel="stylesheet" type="text/css" href="//" />

Can anyone please help me understand what to do? And after it’s added, will it be possible to change weights etc. in the editor like other fonts?

Many thanks

Hey @asssmidt we currently don’t have webfont support. That means you can’t choose and select the fonts inside the designer, but you can specify which classes will have your font in the custom code for your site.

So if you want all of your headings to be Gotham you’d add something like this in your custom code:

  h1, h2, h3, h4, h5, h6 {
    font-family: gotham, helvetica, sans-serif; 

Replace “gotham” with the correct font name found in your settings.

Thanks @thesergie I hope you will connect to cloudtypography soon :smile:

Meanwhile I will use typekit, but shouldn’t I be able to see the actual font in the editor?

I selected Museo Sans Rounded from typekit and connected to webflow, but:

Is this how it’s supposed to be?

Many thx

@asssmidt Try to go to your kit settings and switch the domains around, then republish. That’s a little trick that updates the typekit servers faster.

I hope Webflow will add an ability to upload custom font soon. One problem with cloud font service is that most of them don’t support language other than English. As I’m Thai designer, I just can’t make use of it. I can see the great opportunity to use Webflow service when it’s ready.

Do you have any idea when it will be possible to add custom fonts? I’m loving Webflow so far but it’s impossible to use it on projects for clients which brand has a custom font.

Hey guys custom fonts have been added. You can access them in the Fonts tab in site settings. Enjoy!

@thesergie tried uploading a custom font just now, and its not working for me. the upload button opens up a window, but when i select a font and click open, nothing happens… any help here?

@thesergie my apologies… just ckecked again, it works now… just need to give it a while before the font appears.

Yeah must be a big font that you’re uploading. We’ll try to add an “uploading…” notification.

Custom fonts are now supported natively:

This topic is now closed. New replies are no longer allowed.