Streaming live at 10am (PST)

How do you add images to a blog post

I’m working in the editor and I want to add an image to a blog post where I know the image already exists in my media Library. Seems silly to have to upload the same image multiple times. Am I missing something? This is so easy to do in WordPress. Why is it such a pain with webflow?


You might not have connected the image to the collection.

You should be able to see the images in every collection and each item in a collection and edit that image or replace it with the editor.

Thanks for your reply. Hmmm? Maybe I’m accessing the wrong area. When I get the “+” that allows me to add an element to a blog post, it only gives me the option to upload an image. I don’t see any place where I can access images from a collection.

Did you double-check the collection for an image field?

Yes. I’m familiar with the image field and I really don’t like it. Admittedly I’m relatively new to using Webflow, but from what I see, when you place an image field in blog field, you can’t then move that image around to different parts of the blog post. Simply put, I want to be able to add an image and have the option to upload one, select one from my media library, or import one from a URL. But it’s looking like the only option is upload (unless I used the limited image fields).

Hi @rondawson - think I understand what you mean, as far as I’m aware, there’s no where to access your image gallery/library using the “+” area in the editor.

That said, I’ve haven’t had any issue/inconvenience having to re-upload twice so don’t see 1-2 extra clicks as that difficult - however rarely have the need to do this. Hope this helps!

Thanks for your reply. I figured that may be the case. I guess in the grand scheme it’s not awful, just seems like such a basic feature not to have. :man_shrugging:t6:

Uh… Hey. I think you should set a field for images and plug the image there? Or you can set it as a background. I’m sorry if does not help, I’m still new here.

Thanks for your reply. Using an image field does not help because it limits where you can put images (they can only go where you put the field). There is no way to do what I want to do. I just have to re-upload the same image, even if it already exists im my image library.

You should try formatting your items into a grid, I think it may work.

Also, can you please send me a read only link to your project?

The only way to reuse an already uploaded image inside a Rich text Field bound to the CMS is to inspect the source URL of the existing image, copy that, then use a code embed with an IMG tag and set the SRC to the same value.

Ah! That makes sense. Thanks for the tip. I’ll keep that in mind.