How do I stop search snippets from displaying HTML/CSS?


I’ve been running into an annoying issue: when displaying search results, some of the snippets used display CSS code.
This seems to happen if the relevant search term is part of a header or close to the beginning of the first paragraph. Apparently whatever is generating the snippets hasn’t been instructed to disregard certain tags and simply grabs everything left and right of the first instance of the search term it finds.

It’s easy enough to make sure that headers aren’t used in the site search (although it’s unfortunate that this means disregarding page titles), but with regular paragraphs, this kind of defeats the purpose of having a site search in the first place.

Am I doing something wrong? Is there a workaround for this?

Here’s an example of a query where the first result illustrates what I mean, plus the read-only link to the project:

PS: while looking through the forums for an answer I saw several years-old posts claiming that Webflow’s options for displaying search results would be expanded, including options to set snippets manually. Guess that’s been put on the backburner indefinitely?