Home page won't scroll (overflow not the problem?)

Hi there,

My homepage won’t scroll on published site (it does scroll in the designer) but every other page on the site does. I’ve done some digging on this issue in these forums and the only solution i’ve found is to set the body to overflow visible. Unfortunately, overflow has been visible the whole time.

I’ll provide the read only link and the link to the published site.

Hoping someone has an answer for me.

Thanks in advance!

Here is my site Read-Only: Webflow - FoxFab Website

Here is the published site: https://foxfab-website-7d8276.webflow.io/


It looks like there is your Navbar interaction causing the issue, because on smaller breakpoints I can scroll. (I’ve seen interaction is enabled only on desktop version)

try to Disable Navbar Interaction, then publish your website and see if it Works.

If it does work, I would suggest recreating the Navbar interaction.

Hey Erik,

Thanks for your response. I did give this a go and unfortunately it hasn’t helped my issue.

Open to any other suggestions!

Difficult to decipher since your preview version works. It requires publishing the site to see if a solution will work.

I noticed that you’ve use periods in the names of your css classes. I thought this was an invalid character for a css class name but I may be wrong. I’m not sure that would cause an issue either but you might test using dashes on those names.

hi @Rian_Michelsen you have on second biggest screen set body:{ overflow:hidden} just reset it

You are correct a dot. is used in custom CSS but WF expect in class field only names as it generates dots before selector automatically and convert “literature” mean classes with big letters and spaces into selectors that are in semantically correct format (that CSS understand) means lowercase strings separated with hyphens.

Thanks Stan! Good to know.