Help me Create a Webflow Electron App

Just for fun, I started making a native desktop application for webflow using electron and a tool called natvefier. I have done this with some other sites to practice, but there is the option to edit the application menu bar, and there are several functions that are in webflow that i think could go in my menu bar. I have only previously wrapped sites up as a native application, and usually left the menu bar hidden or with the default actions in it. This would make the app feel more native to the desktop, and maybe I can learn to do mroe cool stuff with it.
Right now I am starting with the keyboard shortcuts. I was wondering if someone could help me out with this though.

This is how the menus are built on the menu bar:
var template = [{
label: ‘&Edit’,
submenu: [{
label: ‘Undo’,
accelerator: ‘CmdOrCtrl+Z’,
role: ‘undo’
}, {
label: ‘Redo’,
accelerator: ‘Shift+CmdOrCtrl+Z’,
role: ‘redo’
}, {
type: ‘separator’
}, {
label: ‘Cut’,
accelerator: ‘CmdOrCtrl+X’,
role: ‘cut’
}, {
label: ‘Copy’,
accelerator: ‘CmdOrCtrl+C’,
role: ‘copy’
}, {
label: ‘Copy Current URL’,
accelerator: ‘CmdOrCtrl+L’,
click: function click() {
var currentURL = getCurrentUrl();
}, {
label: ‘Paste’,
accelerator: ‘CmdOrCtrl+V’,
role: ‘paste’
}, {
label: ‘Paste and Match Style’,
accelerator: ‘CmdOrCtrl+Shift+V’,
role: ‘pasteandmatchstyle’
}, {
label: ‘Select All’,
accelerator: ‘CmdOrCtrl+A’,
role: ‘selectall’
}, {
label: ‘Clear App Data’,
click: function click() {

So I am able to create or edit the way the menu looks, the label and the accelerator, but making it do what I want is where I was hoping for a tip. I tried to look at the main.js of the electron app Inboxer, because they did this with the menu bar to perform functions in gmail, which i think they took from the existing gmail keyboard shortcuts, but they wrapped it in an asar archive and i am having trouble extracting it.

So I was hoping someone could help me learn how to make the menu item do what I want it to do, and also how to extract the asar archive. I installed asar from the command line and tried to extract it but didnt do it right.