Having difficulty updating twitter card when sharing blog post on twitter


This may be the umpteenth time this question has been asked, but I apologize as I haven’t found a solution yet.

I was working on setting up the blog section on my new portfolio/agency website when I noticed that the card wasn’t updating when sharing it on twitter. I updated the graph settings for my cms blog pages and it seems to be updating when sharing the link on facebook, but not twitter.

For example, when sharing on Facebook:

On Twitter,

Website Aesthetics and Functionality Are Essential for Business Websites https://t.co/mkll2lAdzu

— Brian Love (@BLove649) February 5, 2020

Channel Society Twitter Share

It remains as the same card as when I post the link to my homepage.

Here is my site Read-Only: LINK

Thank you so much for your help. I know I know its a relatively minor issue, but when trying to grow business, you want to look like you have some clue as to what you’re doing lol

Twitter is showing the image and content that is referenced in your site source code on the home page. Your template has hard coded twitter card code in the head.

<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@blove649">
<meta name="twitter:title" content="Channel Society">
<meta name="twitter:description" content="Welcome to Channel Society! We are a Los Angeles-based web design and development agency providing our clients with custom mobile-friendly websites that ensure their brand is well represented and respected across all devices and screen sizes.">
<meta name="twitter:image" content="https://assets.website-files.com/5dccc3335095d033aae41baf/5df67348fbd926cc3560c89c_Los%20Angeles%20Web%20Design%20Hero%20Image.jpg">
<meta name="image" property="og:image" content="https://assets.website-files.com/5dccc3335095d033aae41baf/5df67348fbd926cc3560c89c_Los%20Angeles%20Web%20Design%20Hero%20Image.jpg" "="">

Ok so I removed the hard coded twitter in the head and added it to the head section of just the home page and I am still getting the same result.

Ahh now it works…thank you so much for all your help