Streaming live at 10am (PST)

Grid cells won't drag to combine with other units

I’ve been watching tutorials and people keep dragging cells to merge with other cells in the grid. The grid is highlighted in blue and there is a small blue circle in the bottom right corner then the tutorial shows the mouse drag the cell to merge with another cell or cells to form 1 cell.
The thing is on my version the circle is not there and when I hover there and click it doesn’t do anything. Has webflow changed since these tutorials were made? See a pic from my monitor.
I’m using chrome. How can I replicate this action to follow along and properly customize my grids?

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Make sure you don’t have any browser extensions enabled. You can always do manual placement as well.

Thanks Jeff!
How exactly do you do a manual placement?
I tried to select individual cells to change their properties but the whole grid just turns red whenever I double click and goes into editing grid mode. Please let me know or just send a link if there is one I’ve been looking but haven’t found yet.

Browser extensions disabled was not enough.

But. Unin and Reinstalling chrome worked!