Grid autogenerating unwanted rows only on large desktop

Hi, I’ve got a portfolio thumbnail section using a grid. I was editing the responsiveness of it all, and now, on the large desktop, I cannot get a grid to stop autogenerating rows that I don’t want. Creating one tall column. I can’t see any difference in settings between breakpoints. I also built a new section above it from scratch with new classes and found it did the same thing!?!?!!? driving me mad. Can anyone help, please? :slight_smile:


Here is my site Read-Only: Webflow - Christian Creates