Google not using title tag and meta description provided

Hi this is our homepage

We created the homepage more than a month ago (Some of it is based on the Forest theme)

We put our words we want In the SEO title and meta description description.

However months passed and when we search “Ola Tech” we still get this result below…

The result came from the Title, which refers to the top left logo alt text “Ola Tech logo” and the sub tagline (It ignores our main tagline)

We use Google search console to recrawl the site manually and also submit the sitemap (We don’t know a good way to remove the purchased Forest theme stuff, so just put these pages with )

Any help is greatly appreciated!

This is our project’s readonly link:

Hi thanks for reaching out.

​I took a look at your site and it’s really hard for us to tell you why and what Google shows in their result.

​From what I can see the settings from your and our side is correct. Republish and resend the info to Google is the only tip I can give here.

Let us know how it goes.

Kind regards,

Jörn :sweden:

If the page has low traffic, it could take a while to see the results.

Try this in Search Console, it may speed up the indexing of your changes.

  1. Test the page (inspect URL)
  2. Then press the Test Live URL button
  3. Once this process completes, click Request Indexing

BTW, I noticed your homepage and THIS ONE are nearly identical. You should consider assigning one as the canonical to reduce your risk for a duplicate content flag. Also, keep in mind that Google is likely to use the text from your webpage more often than your crafted Meta Description narrative, so craft your opening paragraph or primary header with that in mind.

Let me know how this works out for you.

Thank you Chris and Jörn. Yes Chris I did the search console request indexing couple times already.

Your suggestion of Google crawling webpage vs the meta description is useful. We will recraft our message soon.

That near duplicate one was to test a different mobile hamburger menu. I put "<META NAME=“ROBOTS” CONTENT=“NOINDEX” on it but did not put NOFOLLOW on it so I put both back. I don’t know a good way to “hide” the purchased the Forest theme pages (As purchased theme can be used on the project once so I put all these theme pages that came with the purchases with

If Google can find the matching copy in your description, they’re more likely to use the tag as is. It’s also just a good exercise – figuring out what your core target keywords are and targeting them naturally in your META description (don’t just make it a list of keywords, of course) will help you focus your overall on-page SEO efforts. You can check here the best keywords for your business.

There’s another, much more severe META tag you can use to block your snippet entirely:

<meta name="robots" content="nosnippet">

This directive will remove your snippet ENTIRELY, though, so use it with caution. It can also effect caching. In general, I’d only use this option if Google is taking liberties with snippets that could harm your brand or cause legal problems. Typically, these issues would be better dealt with in your on-page content directly.

Hey Peter how did you manage to fix this issue? We’re currently experiencing the same issue with our logo’s image alt tag being used as the google search result title ignoring our SEO title meta tags.

This is happening for me too, so fustrating. Any help would be great.

Same thing. Even that my domain ir new and it takes a indexing every blog post manually thru search console, and it takes solid weeks to get even on google search and same thing - there is no blog post title but some ALT name from home page title or etc. not blog post title. all post title and meta are created. sub-domain indexing is disabled. Still no changes. sitemap are send two time (found that send it again when do major changes helps googlge indexing faster the changes)