Google not indexing, shows disallow: / but Webflow SEO settings seem correct

Hello Webflow Friends,

Google is not indexing my website:

image

These are my webflow SEO settings:

As you can see “disallow: /” is not shown in SEO settings… not sure why it shows that…

Help appreciated!
Thanks, Piet


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi @pjdbruin,

https://www.iomete.com/ is returning a 404 error message for me. Have you recently updated DNS records?

Let me know and I’ll look into this for you!

HI Milan (@mww ), thanks for trying to help out. I am lost. I unpublished webflow.iomete.io to see if that would help me. I did publish www.iomete.com but somehow I got the 404 error message… I just republished webflow.iomete.io and now www.iomete.com is working again. Something is not right…

Hi @pjdbruin,

It looks like you’re using a reverse proxy - did you set up your DNS records yourself?

@mww I did… What did I do wrong?

All good! It looks like your robots.txt is working now: https://www.iomete.com/robots.txt

@mww Milan, it looks good on the surface but something funky is going on.

These are my SEO settings:

As you can see Indexing of http://iomete.webflow.io is ENABLED. This should be DISABLED. We want Google to crawl and index iomete.com, not the http://iomete.webflow.io or both.

For good order, with the above settings: the result looks like this:
image

Now look what happens as soon as I change the Webflow SEO settings to what I think they should be:

These settings result in the following:
image

I’m truly lost… all help appreciated!

Hi @pjdbruin,

Because you’re using the .webflow.io subdomain for your reverse proxy, this is expected behavior.

If you set up a custom subdomain (ex. webflow.iomete.com) and use this with your reverse proxy instead, you should then be able to Disable Webflow Subdomain Indexing and use your custom robots.txt.

Hope this helps!

@mww Milan,

It helps certainly! But…we’re getting to the point where I just don’t have enough technical knowledge. Is this something you can help me with? Perhaps zoom call as a first step. Happy to compensate you or support charity of your choice… Best, Piet

Hey @pjdbruin,

Drew here from the Webflow Support Team. I responded to your ticket as well. Would you be able to provide some more information about your Reverse Proxy configuration? I would be happy to assist more.

Are you proxying more than one hosted site to your domain? Or just your Webflow site? Just wondering if it may be better to just use the default Webflow DNS configuration.

Hey @Drew_Schafer and @mww , Your pointers were sufficient for my technical co-founder to be able to figure this out. Thanks for your help. Issue resolved.

2 Likes

Get help with setting up meta data, dynamic SEO settings, and more.


#SEO Help Category

Get help with setting up meta data, dynamic SEO settings, and more.

#When posting please:

  1. Share your project’s Read-Only link AND live site’s Published link
  • The read-only link is a special url generated in the Dashboard to allow others to view your project in the Webflow Designer. How to get your project’s read-only link?
  • The published link is the webflow.io subdomain where you can view the live site with custom code running. It is important to share this link, as custom code does not run in the Designer.
  1. Upload as many screen shots/screen cast videos as possible to help others help you faster
  2. Add a description and/or post a link to a working example of what you’re trying to achieve
  3. Reply to users by tagging using the @ sign followed by their forum username like this: @Waldo