Google Analytics causing an error "no value passed for parameter 'siteSlug'

After Following the instructions, adding in my GA Measurement ID and pressing save changes, I get the following screen, and it doesn’t work. What does “No value passed for parameter ‘siteSlug’ mean?”

Does this have to do with that my website domain uses a .studio?

Read-only Link to website


I have the exact same issue. Hope someone knows what is going on…

I also have the same problem…

1 Like

Same issue, when I try add the Facebook pixel

Did you guys tried it for a test-URL? I get the same error and have a sense that it has something to do with the test-URL and that I haven’t launched this website yet…

Same error on a .com domain

Hi all, same issue here on a .com domain.

Cleared cookies and cache. Tried Chrome, Chromium, and Firefox. No luck.

Help Webflow devs!

Same bug for FB Pixel integration: Facebook Pixel Integration Bug

Same issue for me. Would love to have this solved.

Hi everyone,

Thank you for flagging this issue. Our team is aware of it an actively working on a fix.

In the meantime, a potential workaround could be to use the embed code directly from any of these tools and place it in the custom code section of your site.

I will follow up the moment I have an update on this. Thanks for your patience as the team works on this!


Update: Our team has deployed a fix for this and you should now be able to save changes on the Site Integrations page as expected. Thank you for the patience as our team worked on this.


Thank you all so much for chiming in and helping out!!! I am glad others validated this as an issue and that it’s been resolved. Great work Devs!!!

1 Like