Fullpage scrolling does not working

hi.
I took the code for fullpage.js and put it on my web.
I wanted to move to the section by putting the number on the left. I added an id value to the section and it worked well in preview mode, but it didn’t work when published.
So I put
-> anchors:[‘firstPage’, ‘secondPage’, ‘thirdPage’, ‘fouthPage’,'fifthPage’, ’sixthPage’]
in my body .

Then, automatic scrolling is no longer applied. What should I do?


Here is my site Read-Only: [LINK][1]
([how to share your site Read-Only link][2])

not working website -> https://www.jaebin.kr/

Hello @JBBI,

Cool website! The animations look great. I think you have to add some more code to what you already have in order for the anchors to work with the fullpage js library. Try this:

$('#fullpage').fullpage({
    anchors: ['section1', 'section2', 'section3', 'section4', 'section5']
});

You already have the rest. Please let me know if that works. Take care.

Hi !
Thank you for your reply.
I tried as you advised but it still doesn’t work. Sadly., but I think I should get rid of the page-movement option…

Hello @JBBI,

I wonder why it doesn’t work? Another option that is to use the html attribute data-anchor="section1" in each section in order to define the anchor for it. something like this:

<div id="fullpage">
    <div class="section" data-anchor="section1">Section 1</div>
    <div class="section" data-anchor="section2">Section 1</div>
</div>

In Webflow you will have to add the attribute un each section settings
Screen Shot 2020-12-15 at 10.26.52 AM
If you try that, please let me know if it works.