Streaming live at 10am (PST)

Form Target Attribute

Hello Community,

I am configuring a Form element, and I am wanting to set the Form’s target attribute to “_blank” … is this possible? I did find the Custom Attributes section in the Settings tab, but it says “target” is reserved.

Thank you,
Michael

I do believe that @brryant or @callmevlad made the Target attribute function reserved for other purposes.
@cyberdave may know on this one?

Hi @MikeEEE, you can actually edit the form’s “action” attribute directly in the Form Settings:

However, this field requires a valid URL, so you’ll have to trick that field into accepting a _blank value (which is not a valid URL). You can enter the “back tick” character (which you can type by pressing Shift + ~ on most keyboard) right before the value you want to skip validation in order to force Webflow to accept it.

So in this case you’d type something like this and hit Enter:

That will make sure your attribute is set:


A Big Fat Disclaimer :tm: --> Webflow does not support this non-standard use of forms, and we can’t guarantee that form submissions will work properly once you make this custom change :grimacing:

1 Like

Wow! Thank you for that… however, it’s not the action attribute I am looking to modify, but the target. :smile:

1 Like

Haha, derp, I should learn how to read before taking a bunch of screenshots :smile: Let me think of that for a bit…

1 Like

LOL… well, if it helps, I found it a most impressive and informative answer … that also just happened to not actually answer my question! :laughing:

2 Likes

So the target attribute is reserved mostly because Text Links and Link Blocks have a “Open in new window” setting that sets the _blank value on the target, so we’re doing some testing to see what would happen if people accidentally do both - set that checkbox on a link and add a custom attribute with the target name. Stay tuned…

1 Like

Ah OK… so am I to understand that the current reason why I can’t add a target attribute to a form is that it has nothing to do with the form itself?

You should enable the -> ` <- for attribute overrides. :smile:

Actually we just pushed a change to make sure that the “target” attribute is no longer reserved - so go nuts :smile:

2 Likes

WHOA!!! That’s awesome!!! WICKED FAST! OMG you guys are so awesome. Your product is simply lightsout amazing. I can’t speak enough about how awesome the designer is. I am (obviously) from a MSFT background so it’s been a cluster with building client applications for a while now. So this is a BLAST of fresh air.

In fact, I opened up my Office365 account yesterday and saw that they were promoting a new sharepoint designer. All I could think was… you should license Webflow to them.:wink: For serious, haha.

Really incredible. I’m happy to pay for hosting and to support the cause. The fact you can address a bug reported on your forum within a day is UNSPEAKABLY REMARAKABLE! Thank you!!! :smile:

3 Likes

Boom! Works like a champ… my search now opens in a new window, and is searching off my Tumblr blog! Thanks again!!!

http://microsoftwins.com

2 Likes

@callmevlad thank you so much for pushing this update! Wow that was fast :slight_smile: #winning :grin::grin::grin:
YOU ROCK!!!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.