Form submissions coming in blank

Hello there,

Hi there,

I’m facing a problem with the form, as it continues to send blank emails even when my customers provide all the required information. I attempted to recreate the form, but unfortunately, the issue persists and nothing seems to be working.

Two possibilities come to mind;

  • You have modified your form’s body template under your site’s form notification settings, and you are not including the data macro. Check that page for instructions.

  • You have a script running on the page which is acting on form submit, and deleting that data just before the Webflow.js submit handler picks up the data.

Check your form submission history on your site settings form tab at the bottom, if you see data, then you’re getting it, and #1 is likely the problem. If you’re seeing submissions but the data is missing, then #2 is probably it.

1 Like

Hello, Thank you for getting back to me. I reviewed my scripts thoroughly, even removed them to have a bare form with no code, yet there’s still no progress. While I am receiving the data, unfortunately, nothing is being sent to my email.

Hi Christopher,

Did you check your site’s form notification settings?
My #1 above, that’s the most likely scenario.

Clear out your custom body field, save, publish and test sending a notification.

I’m curious to see a screenshot of your site’s form settings page as well to see if my theory is correct.

Hello, I did indeed review my site’s form notification settings, but unfortunately, nothing has changed. I’ve cleared out all custom body fields, saved, and published the changes multiple times already. Despite this, there’s been no improvement. Here are screenshots of my notification settings and an example of the email I receive when information is submitted. I do receive the data, and it’s all visible under my form submissions.

Do you see the Email template field there? You have some custom text in it, but you don’t have the formData included.

Empty out that field, save and publish. You’ll get the default configuration which includes the data.

1 Like

Thank you! This worked flawlessly! It’s astonishing how a simple fix resolved the problem that was causing me so much frustration! Your assistance is greatly appreciated!

1 Like