Streaming live at 10am (PST)

Form submission not working

Form submission stopped working on my site.
I deleted the form and inserted a new form.
This has not cured the problem.
Any ideas as to how to proceed?

HI @Gemini2

Can you expand on what is not working?

Are you unable to submit a form, or is the form not being received?
Have you checked in the Form Settings in the project dashboard?

The preview link needs updating as it returns a 404…


Thanks for posting – I’m standing by for your response to @StuM’s questions as well.

It may be worth mentioning that if you are exporting your project, form submissions will no longer function.

This change was made to stay compliant with GDPR — we discuss all the details more in-depth in a blog post, but here are the updates that may be causing this issue:

This means that, starting on May 25, 2018, sites exported from Webflow will have the form submission source code removed, and exported code will need to be manually hooked up to another mechanism or service to capture form submissions.

If this change will affect any of your sites, you might want to look into sending form submissions via MailChimp, or other third-party tools like Formstack or Wufoo. Here are some general instructions on using third-party tools for managing form submissions.

For sites that were exported before May 25th, we’ll continue to record form submissions until July 31st, 2018, to give site owners time to transition. After that point, form submissions for exported sites will no longer be stored on our servers.

If you are not exporting this site and the form is still not working as expected, please let us know and we’d be happy to investigate this further.

Hi there StuM and Brando,
StuM, sorry for the late reply to your post.
Thanks for looking in to this.
It turns out that I did not know (and I should have) that exported web sites need to be hooked up to another service to capture form submissions.
I found a post in the Webflow knowledge base that listed some suppliers and used Formspree.
This works fine on the two sites that I have exported and now the problem is solved.

1 Like

No problem Martin - it’s a fairly recent change! Glad you’ve got a solution sorted.

@Brando - I’ll recategorise :slightly_smiling_face:

1 Like

Thanks for the update @Gemini2 and for the help @StuM :raised_hands:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.