Form Submission Not Working iOS 13


I have issues submitting forms when using recent updated iPhones. The form resets itself when hitting the “Submit” button, without completing the process.

No problems with iPadOS and iOS 12, so I guess the bug could be related to iOS 13. Does anybody have a clue?

Thanks for your help.

Here is my site Read-Only:

Here is my Live-site: Admission & Application

I tried with Chrome on iOS 13 and the form submission has the same behaviour.

Hi, @SaulPanofsky!

Ben here with the Webflow Customer Support Team!

Thanks so much for reaching out about the issues you’re seeing with your form and iOS 13. I did some testing on my end and I wasn’t able to reproduce that same behavior.

Can you let me know what model iPhone you were testing on and what software version it was running? Also, have you tried on multiple devices running iOS 13?

I’ll be standing by to help on this end however I can!

Hi Ben, thanks for your help.

I did a test moments ago but I got the same odd result.

My device is an iPhone XS Max running iOS 13.1.3 (my first test was with the previous version 13.1.1) Unfortunately I have no access to other iOS 13 devices, at the moment.

What model have you got? Could the problem be related to just the Max Version?

Hi Saul,

I am not seeing the behavior on my end on iPhone XS on iOS 13, although I only have access to iOS 12 on XS Max, see here: Screen Recording 2019-10-22...

Do you have some screenshot showing how the form “resets” ?

Hi cyberdave, thanks.

It basically resets the page, going to the top of it and the application fields become blank. If helpful I could make a screen recording of the process.

Btw, I found out that the issue is not happening on Webflow’s subdomain ( but just on my custom domain Admission & Application.

Hi there @SaulPanofsky, that is really strange for sure.

One thing to note is that Webflow publishes the same code for all domains and browsers, so most likely it is some kind of caching issue with iOS 13, I have seen myself cases where websites like and do not completely load or reload, so I do not think it is a Webflow specific issue. (the issue would affect all domains if that were the case).

Another thing, it looks like the site might be using some custom code or custom html embeds, I would remove all custom code and then retest as custom code issues can also cause these kinds of problems.

You might also setup a Preloader which will make sure that all page files are downloaded before the user start to type in the form, it could be that the files are not yet downloaded when they start typing and when the page load completes safari sets the user to the top of the page.

I am continuing to check on that to see if I can reproduce the issue

I have tried removing custom codes with no luck.

Here is my screen record: iCloud

I’ll definitely consider your suggestion to setup a preloader. Thanks @cyberdave.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.