Form settings > Source option hidden

Hi folks,
I have an issue with Form settings. I’m trying to set up HTTP request to my page according to this tutorial but I’ve got stucked already on first section when I neet to change Source of the form - I don’t have this option in my page.
Screenshot 2023-02-15 at 13.17.58

I cannot find any reason or solution so I’m trying over here. Thank you in advance for any help🙏🏼