Font Upload is not working correctly

Hey guys, has this been happening to anyone else? Normally I can just drag and drop a bunch of fonts when uploading custom fonts but now that no longer works. You have to select one font at a time and completely install it. If you upload a font then try another without clicking “install” then Webflow completely crashes and gives you a white screen.

Just wondering if it’s just me. Of course you can still upload fonts but when you have a font with a ton of variations it’s just a bit tedious.

2 Likes

Not just you, it is happening to mee to. Extremely time-consuming, and so stressful when all variations are loaded as a singe font - i need to change the font to be able to change the weight. Hopefully they will fix it soon - I think they changed something with the way one upload fonts as the design is abit different as it used to be. But yeah lets hope they fix it soon.

Yeah why is this not fixed yet…? It’s so frustrating

I can’t upload any fonts at all. Is it still loading just one at a time for others?

Same here, I can’t upload any fonts. They even not appear in my file selector to upload.

I am also experiencing this issue. I can’t upload custom fonts. They don’t even appear in my file selector. The Google Fonts API does not allow you to specify fallback font rules. This creates an error in Google Lighthouse.

2 Likes

Hi, I can’t upload any font either…

The font/file selector window now only filter WOFF or WOFF2 filetypes. In order to access the OTF and TTF, we’ll have to pressed the dropdown on the right bottom label “Custom files” change it to “All files”

But yeah, it’s pretty annoying that we STILL can’t upload multiple at once. Gotta upload it 1 by 1.

2 Likes

this was really useful. thanks

Thank you Charles for the dropdown tip!

On Mac, you have to click the Options button on the bottom left of the file selector window to get the dropdown of file types. I had to click on a file in the selector for it to update the file names to not be greyed out. Here’s a screenshot of what it looks like on Mac

Thanks for the drop down menu tip but I still get an error message that webflow doesn’t support OTF or WOFF2. Any ideas? Webflow article says it does support these file types.

yes this also is happening to me. fonts not working for me. not even custom fonts. can’t figure out what is wrong, been working on adding a standard font for almost an hour now. very frustrating

My entire browser freezes/crashes when trying to upload a font.
Anybody else have this issue?

PS. this issue was solved. (see below)

@icexuick No issue for me.

I found the problem for me - it was that somehow the upload window got hidden behind other windows. Resizing the main (Webflow) Browser tab and making it smaller made the upload screen/explorer appear. So this is solved for me.

Hello - and for all those for whom this does not work either, I recommend using a different browser - works for me :slight_smile: