Finsweet CMS filter - active state

I can’t get the CMS filter checkbox active state to work, despite following instructions.

The CMS filter itself is working as expected so far (only a basic implementation)

If you check my readonly link & scroll to the bottom - then click ‘SPORTS’ the collection list will filter, but the SPORTS button/checkbox stays white instead of turning purple (which it should as it should be ‘active’)…
(actually - for some reason the CMS filter isn’t working on the readonly link - yet it works on my published site?? this is my first post sharing a link this way perhaps I have done something incorrectly?)

Would anyone be able to help?

I’m using

And checkbox#4 from here (followed the instructions in here)


Here is my site Read-Only: [LINK]1
(how to share your site Read-Only link)

Hi Jamie,

Have a look at Finsweet’s docs page, at the source code of the page where the examples are. I recall it doesn’t use Webflow’s active state, it adds a different active class, something finsweet-specific. When you figure out what class that is, you’ll add it to your items and style it how you want.

You can also look at some of their cloneables, they should demonstrate this as well.

The CMS Filter is code-based, and custom code only runs in the published site.