Streaming live at 10am (PST)

Field must not be empty

Hello,

Could someone please help me pinpoint the issue that is causing there to be an error message in my Zoho form when I click submit?

I’ve been running tests on a dummy page before going live and I’m able to send the lead on desktop (and desktop mobile/making the screen smaller) but when I try to test it on my phone, I get a popup saying ‘Name must not be empty’. Obviously, the name is not empty when I try to submit.

Any ideas as to why it isn’t working on mobile?

Thank you!

https://preview.webflow.com/preview/bonjour-sante-media?preview=47d5c8308ccc27449e46082f561422d1

Here’s the page I’ve been testing on:
http://media.bonjour-sante.ca/contact-copy


Here is my public share link: LINK
(how to access public share link)

Where did you get the validation custom code from? Obviously some setting does not match your form fields.

I exported the source code from Zoho directly

Oh I see that you have the form embedded twice on the page. That will not work.

I had to create a mobile version because the fields were too long.

As someone who doesn’t code I didn’t know how to make the form responsive.
I would definitely prefer that option, though!

The fields have a fixed width. Just remove anything that matches width:###px from the code, or replace with width:100%

Ok, so I did that, but I got this:

I tried putting it in a div block, limiting the width, none of it seems to work.