Favicon and Webclib not working

Hello. i designed a website and when I export the code, to place it on a server, the favicon and the webclib were not exported. When I manualy place them in the ‘/icon’ folder nothing happened, accept a 404 error. This because the icons are loaded through javascript?

Now I have to go into the code and change the path from ‘/icon/’ to ‘/image/’ and upload the favicon and webclip png’s to the image folder.
Now it works.

Send three emails about this to support, but didn’t get an answer. Anyone else have the same experience?

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Rename your png or ico really to favicon.ico (or favicon.png) and webclip.png and upload it again to into webflow… Then export the code again :wink: This worked for me just 1h ago :smiley:

1 Like

Thanks Matzinger for your replay. I get it working, but this isn’t how it should work!
In the past it worked fine, now not anymore.
I can’t get a respons from Webflow themself, so …

1 Like

I have the same issue.


Ben here with the Webflow Customer Support Team! Thanks so much for reporting this issue! Our team has pushed a fix for this and everything should be working as expected now. You may need to clear your cache in order to see those icons showing up again on export.

If this doesn’t resolve your issue, please comment back here and I’ll be happy to assist you further! :webflow_heart:

1 Like

Not fixed at all. Have several EXPORTED sites now missing favicons.

Have uploaded the files to both images and icons folder, but still no favicon appearing, even after clearing cache. Having to edit path on every pages code. (Not acceptable). Please can you confirm this has been reopened with your team?

As an aside, I would much prefer not to have to have to jump through all the hoops to export, but Webflow hosting is way too expensive for basic sites. In the UK 1&1 are offering hosting for £1 per month - that makes Webflow hosting a hard sell for static brochure sites.


Thanks for the update and sorry to hear about the continued issues.

When you cleared cache, did you do so before exporting your site, then try re-exporting? If not you’ll likely need to take the steps in that order:

  1. Clear cache
  2. Export site
  3. Upload files to your hosting provider

You should be able to see the favicon & webclip images exported before uploading to your hosting provider.

Please let me know if this helps, or if you have any other issues.

Regarding your point on pricing — I hear you! There are definitely much cheaper options out there. However, those £1 priced hosting options are vastly different products than Webflow Site Plans.

Webflow Site Plans include managed hosting with free SSL, a global CDN, a proven track record of over 99% uptime, a visual CMS, client-facing Editor, CMS API, password protection, etc.

I’m happy to dive deeper into the why of our price points if you’d like, but for now, I definitely reccomend checking out this excellent post:

Hi @Brando Nope - its just undone all my manual page edits to point to the images folder instead of icons :tired_face:.

The Webflow code points to the icon folder, but the favicon located there isn’t displaying. I had to upload the files into the images folder and then edit the page code to point <link href=“images/favicon.png”

Re pricing, yes clients that require CMS understand the addition hosting fees, and to be fair $16 p/month is good value. However, the entry level tier at $12 is just too high for a basic website for a builder/beautician.

I have a re-seller hosting account which costs me $4 per account per year, I get free SSL and unlimited email. As a freelancer, that’s where I make my ongoing money, my Webflow hosted clients make it hard for me to get a slice of the pie.

1 Like

Thanks for the update on this @RugbyWebDesign

I’ll reopen the ticket with our engineers — in the mean time I think pointing to the images folder is the best workaround.

We’ll post back here when we have an update on the issue.

And thanks for sharing more feedback about your particular use case with Webflow — the context definitely helps clarify. :bowing_man:

1 Like


You may have done this, but if not, can you please try clearing your browser cache from the last 7 days? One of our team members was also affected by this issue and going back 7 days resolved the issue.

It also looks like exporting in incognito may resolve the issue too (not an ideal solution).

Please let me know if either of these options helps.

Hey @RugbyWebDesign!

Per what @Brando said could you try exporting from an Incognito Mode of your browser?

  • CTRL + SHIFT + N on Windows
  • CMD + SHIFT + N on Mac

Let us know if that helped! We’re looking into this in the meantime tho.

Hello bart!
I encountered the same issue (iMac, macOS 10.14.6, Safari 12.1.2.)
Clearing the browser cache didn’t resolve the issue, but exporting the site from Weblow via incognito mode worked fine!
I hope, that this is only a temporary workaround and there will be a viable fix soon.

Hi All, I have a fix/resolution for this issue regarding “favicon” this is happening if you are hosting your own web servers the “icons” folder is part of Apache and this is a alias folder and therefore it is not listing.

Here is how to get you favicon working again: https://www.fountaindigital.co.uk/itfixes/favicon-fix

Hope this helps

Danny :wink:

C’mon guys and girls at Webflow - Have we still not got a fix for exported sites and the missing icons?

I appreciate the fix suggested by @Nosher but thats way over my head!

1 Like

This solution is not addressing the core issue, which is that the export feature is broken on the icons being included in the ZIP.

After looking at the index.html, even if the assets where uploaded with another name, they are being handled by default as favicon.png and webclip.png; this approach is not bad on the export, but the assets uploaded don’t match and this might be part of the problem.

In practice, once I download the ZIP, I can manually add the assets to the icons folder and just rename them as favicon.png and webclip.png, and it works. But for a less coded approach, this shouldn’t be done and the export should handle the name management adequately, just as it did before =).

1 Like

Not very satisfying! The „favicon issue" still exists.
Some weeks ago, all worked fine and the favicons were accepted and shown in the browser without any hassle.
Now, the only way to reconstruct the former behaviour seems to export the site date using the browser’s incognito mode.
Will this issue be fixed or do we have to live with this inconvenience?

Yes, this is still an issue. I’ve had this problem for a couple of months. Use to work ok, so don’t know why there isn’t a fix.

Hi, @mgonzalez, @mac_heibu, & @angcanada!

Thanks so much for posting and sharing. If you clear your browser’s cache or export using Incognito or Private mode you shouldn’t see the issue.

The team is working on an additional fix that should solve this. I will post here as soon as that goes live. Thanks for your patience! :webflow_heart:

1 Like

Hi, everyone! The team just pushed a fix for this and you shouldn’t be experiencing this anymore! :smiley: :webflow_heart:

If this doesn’t resolve your issue, please post back here I’ll be happy to assist you further!

1 Like

Thanks! It is working for me! =) Great job team.