Failing to Name my design elements - buttons, Nav bar menus etc

Hi Guys,

i’m a Newbie to Webflow. Just went through the webflow crash course and now im trying it out for myself and i’ve immediately hit a bit of a wall - i’m failing to name any of the elements i’ve dragged to my canvas by double clicking on the element and well, typing a relevant name. i dont know whether this is because im currently using the Starter/free account??

i know its a very basic question (naming elements), but its proving to be quite a not so basic problem…

i don’t have much to share about my site because i ran into this problem at the very start of my design process. i had just managed to add my section and a button which i cannot name…

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

1 Like

Hi @Rutendo,

I have created a small video adding a Button, changing the button text and creating a class.

Can you try and post your result with your read only link?

Hope this helps :slight_smile:

Hi Sonia/Nita,

Thanks for your response and video. However i have tried to double click and rename my webflow elements as illustrated in the webflow crash course tutorials and your video without any success. Also tried the following:

  1. In incognito browser mode
  2. Tried clearing my browser history and restarting my computer
  3. Tried on both the latest Google Chrome and Safari browsers
  4. Tried on a different computer
  5. Tried on both a blank and template project

Still cannot rename existing elements on the template

Hi @Rutendo,

You just mentioned that you’re using a template? Can you please post the site Read-Only links please?

It might be a Z-index issue, but without being able to take a look at your project, I cannot have a full understanding of what you might be experiencing.

Thanks in advance! :slight_smile: