Extra space on side of page

Hello everyone,

In the designer, I do not see any extra space on the sides of my page but on the published version, a scroll bar appears at the bottom and lets me scroll to the right which shows some extra white space.

Any help would be much appreciated, thanks!

Here are the links to the published site and the preview.


It seems to be due to your scroll animations that this is happening, but what you can do is go your page settings and enter the following code into the head section:

body {
overflow-x: clip;

Let me know if this helps or if you are still having issues.


This is very common! We created an article and video to cover this topic: Overflow: hidden | Webflow University


Yep this definitely helped, thank you! Do you think the Webflow team will add the “clip” option to the current overflow settings (I assume it is a new option similar to “hidden” that hasn’t been added yet)?

Just added that bit of code to the pages affected by the white space issue and I noticed that the “our team” page still has this issue. Any ideas on what could be happening?

@Chris5 Please try this code and let me know if it works across all pages with the problem.

body {
overflow-x: hidden;

If that doesn’t try setting an overflow of hidden the hero section within Webflow, since that is where your animation seems to be happening,

1 Like

Yep that works thanks again. May I ask when you would use hidden vs clip?