Exporting website not work properly when uploaded on own hosting

Very weird issue happen when I upload all the exported code to hostinger (tried with two different domains)

In the webflow.io subdomain it works properly, but when I open my own domain it freeze in black, literally no clue what is happening.

Also I tried to copy the exact code from the webflow.io subdomain and upload to my domain and it “works” but totally wrong with the CSS (yes I set up correctly the link to the css page)

https://wobrandmake.webflow.io/ (working properly in webflow subdomain)
https://wobrandmake.com/ (Not working)
Webflow - Wobrandmake (preview link)

Any help is much appreciate.
Thanks.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hey Bimbi, it’s looking fine on my Chrome+Win. My guess is your cache has an old version perhaps?

Hey thanks for your time, tried to clear the cache but still not working, it keeps in black no matter what

If it’s not a browser cache issue for you, perhaps a browser extension? Try viewing it in Chrome Incognito.

I’m in NZ currently, here’s what I’m seeing…