Streaming live at 10am (PST)

Empty blocks are disappearing/hidden


I’ve recently encountered this problem… Blocks are hidden (those in which I drag&drop stuff). As you can see on the video below there are some problems with them being displayed properly. I have to move new blocks on the panel on the right side. It happens at Chrome (Incognito Mode too), and Safari. Firefox seems to work wine, but there are some other issues that don’t let me work on Webflow using FF.

Can’t seem to reproduce this problem. @bartekkustra could you check the javascript console to see if there are any errors? Thanks for capturing the video!

This is the only error I’m getting. It happens when I load the webflow editor.

Here is the better screen :stuck_out_tongue_winking_eye:

But I realized it loads every time I go on webflow. Even at dashboard. I don’t know why the bug from the first post happens to me. If I come up with a solution, I’ll post it here :wink: CCleaner didn’t do the work ;s

I’m seeing the same thing that @bartekkustra’s video shows in a new test site. Here’s a troubleshooting link, if you can see the elements in the wysywig view, then it might be browser related.

This seems like it might belong in the “I’m stuck” category…

Allen Same here :frowning:

@ramatsu By default empty elements have a default height of 80px (so that you can see them). When you give it a height it will override this 80px. So it seems you have the Height set to Auto on the BackgroundTest class. Setting it to Auto with nothing inside of it is like setting it to 0. Remove that property and it should be fine.

Does that help?

Sure does, duh. Sorry for the head-slapper.

@bartekkustra if you set 100% height on an element it doesn’t do anything unless its parent container has a specific calculated height (using pixels). That’s why it’s so hard to make something “fill the page” using CSS. Remove the height property from your class and you will be fine. Drop something into it and it will have a height based on the content inside.

@thesergie I understand what you ar saying, but I also understand that the problem persist. I’m having another issue which is shown on the video here: I don’t see new blocks to which I should be able to drop new stuff. It’s just so complicated.

And to set the height of a container to 100% it’s easy to do with jQuery. All you have to do is to link to jQuery in the custom code in dashboard. After that you have to check the height of the window and set the height of the container to it. I’ve recently create a topic explaining that :wink:

Sorry about that @bartekkustra, I assumed it’s the same problem, but you’re running into a bug that we have been seeing a lot lately. We’re going to look into it and see what’s going on.

What Chrome version do you have? And you’re on OSX Mountain Lion or Lion?

Chrome version 30.0.1599.66
OS X 10.8.5

We’re having trouble reproducing this bug. :frowning: Is there something you installed on your computer lately? Or maybe a Chrome update that happened before the bug started appearing?

@bartekkustra, still trying to reproduce this. Can you please let me know if you see any errors in your Chrome console right after you drag a new Block (or Columns) onto the page? Thanks!

Nope, no errors in console. SAme thing happens in Incognito Mode. Chrome was updated recently twice, but the bug appeared in another time, before chrome update was taken. I’m trying to get you on skype, but can’t reach you ;s

Hey Bartek, can you open the chrome inspector while in Webflow, inspect the empty element and see if there’s anything inside of it. We do a calculation to see if the element is empty and then we apply a class to it so it’s a certain pixel height. Maybe your browser is putting something inside of the empty element.

We just pushed a fix for this bug. @bartekkustra can you see if this fixed it for you?

FIxed! Thanks! :)))) What was the problem?

We had a super funky bug in our empty container algorithm, so we had to rewrite some code. Glad it works now!