Embeding mailchimp form

Im trying to add a mailchimp form that will allow visitors to sign up to my mailing list.
I used an “embed” block, and pasted in mailchimp’s code (with my own CSS revisions)

When I see that form in the actual published site, the whole <form> tags are removed from my embedded code, including the form action. This breaks up the functionality and doesn’t submit it anymore.

Any ideas what went wrong?

http://meekan.webflow.com [form is currently at the bottom of the page. I will add it to the top as well when I figure out how to make it work]


Hi @mmatty - you don’t need jQuery coding to do this. It’s actually quite simple.

The easiest way to embed a Mailchimp form is through their embedded form option.

  1. Choose “Signup Form” in your list settings:

  2. Select “Embedded Forms”

  3. Configure your form, then take the code from their “Copy/paste onto your site” textbox and drop it into our embed:

That should work just fine. You can see a live example here: http://test123.webflowtest.com/

@mmatty - I just took a look at your form and it seems like it’s missing a bunch of things that Mailchimp requires for the embed. Make sure you choose “Embedded forms” in Mailchimp like I described above when you create your form.

1 Like

@brryant thanks for your detailed answer
I was actually going about this in the correct way, the same way you suggested. But as Vlad from Webflow support was kind enough to discover and point out, I had a missing parenthesis there, and when I was publishing, Webflow got confused and fixed it by taking out the whole <form> tags
It seems to be working properly now.

1 Like

Hi guys,

I’ve tried doing this but the Mailchimp form’s text doesn’t display.

See below:

My site address is http://african-phosphate.webflow.io/

I would recommend using Zapier instead of the MailChimp embed, that way you can keep the Webflow styled form and still have the emails added to Mailchimp.

Thanks, I’ve tried, but the form wont integrate with Zapier.

I keep getting this:

At which point in the process is that error occurring?

For some reason it’s now working!!

1 Like

My experience with Zapier is not that great. When a website visitor is on a landing page, and just filled out a form to receive something via email (Mailchimp autoresponder) you don’t want them waiting 10 minutes (5 minutes with the upgraded Zapier plan) for Zapier to fire and send the form data to MailChimp. You need that stuff to happen right away. It should never take more than a minute for data from webflow to reach MailChimp for an autoresponder to reach back to the website visitor.

Zapier is fine for building archived versions of form submissions, but not for the primary method of transferring data.

Has anyone had trouble with Zapier not picking up form names?