Embedded HTML Not Working on Mobile

Hi everyone,

I need help with my Request Service or Quote page.
The embedded HTML is working on web, not on mobile. How can I fix this?


Here is my site Read-Only:
https://preview.webflow.com/preview/the-monitoring-centre?utm_medium=preview_link&utm_source=designer&utm_content=the-monitoring-centre&preview=d7a26ad669a68575555548206ad37179&pageId=62d784bf56c60b7558b5f6aa&workflow=preview

Hi @aliciatmc,

This looks like a browser issue - cookies for cross-site resources are now blocked by default (iOS 13+). Source.

On iOS, if you go to Settings > Safari and untick ‘Prevent Cross-Site Tracking’ then refresh the page in Safari, does the iframe work?

Hi @mww
Thank you for your response.
Yes, it did work! How will I know this will work for other people though?
This is going to be a landing page where we send clients.

Hi @aliciatmc,

I’m not an expert on this but I think it’s related to the link you’ve added having tracking scripts on it.

You can test by replacing the link within the iFrame with src=“https://www.webflow.com” and it should display on iOS devices without having to disable ‘Prevent Cross-Site Tracking’.

If this is the case then the issue is stemming from servicem8 so it may be worth contacting them about this issue.

Sorry, I wish I could be of more help. It would be great if someone else who knows more about this could jump in to clarify any info.

Hi @mww
I changed it to webflow and it still didn’t work! Thank you for your help though.

Hi @aliciatmc,

Interesting - would you be able to try visiting this site on your mobile: https://iframe-testing-59f24d.webflow.io/

I’ve added both your embed and then a Webflow embed as well and only the Webflow embed is working:

@mww Webflow works but mine doesn’t. Very interesting.
I will speak to servicem8 and see if there is anything they can do. I searched this issue on Google and a lot of people have this issue. Can’t find how to fix it though.

1 Like