Embed code working on one site, but not another

Hi there,

I am working on a site for a client, they inserted some interactive embed code in a test instance. It works in their instance, and if I duplicate their site, but in the new site that I created, it is not working.

I tried copy and pasting in, recreating every aspect of the styles etc, to no avail.

Note: there is no header/footer code, only the small embed code in the embed module.

Here is the original site where it is working

Live URL

Site I am building

Live URL

I dug around the forums for a similar issue, but couldn’t find anything similar. If there is, I apologize, please point me in the right direction and I will explore.

Script is triggering Google Analytics events. So Google Analytics looks like a requirement. GA is loaded on site #1, not on #2.

@webdev Thanks for the reply. That is definitely something I didn’t consider! Looking at the project settings, I do see any difference in the integration settings or a GA tracking ID in site #1.

Is there somewhere else I should be looking to match things up?

I saw no other issues. Add GA to your project and test.

@webdev added GA and it didn’t work. I will poke around a bit more, but any other suggestions would be appreciated. Thanks!

I believe you need to run analytics.js. Or remove all the GA calls in the script if you don’t need events.

Just to follow up on this, I ended up just copy and pasting all of the elements in the new site to the original test site that was working.

There wasn’t a difference in how the sites were set up with GA, so no clear solution but it worked for this case since I was only working on the landing page for a V1.